Symptom
The completion pop-up is displayed at the end of the content, despite the survey being required for item completion
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- User launches item >
- Item is completed >
- Completion pop-up is displayed despite survey still being locked
Cause
The completion pop-up is displayed because all the content within the item has been completed.
If at the Item configuration > Online Content configuration tab, both "Add to History on Pass" and "Add to History on Completion of All Content" are unchecked, the system will not add the item to the user's learning history, even if the content is completed. That way, the survey will remain locked until an admin adds the Learning History record for this item to the user record.Once the administrator records the learning history, the required survey will be assigned to the user. Upon completing the required survey, the item will be marked as completed and moved to the learning history.
Resolution
At the Item Configuration level, check either "Add to History on Pass" or "Add to History on Completion of All Content" so that the survey will be unlocked immediately after the completion of the content. In case none of these settings are unchecked, the item will not be automatically added to the user's Learning History, even if they complete it, and the survey will not be unlocked unless the admin adds the item to the User's Learning History record.
Keywords
survey, complete, pop-up, item, automatic, add, learning, history, record, unlock, required, completion , KBA , LOD-SF-LMS-EVA , Surveys , Problem