Symptom
- Encountering an issue while testing the SOAP API (Inbound Delivery - Create (B2B)) for the creation of inbound deliveries via the interface.
- Error message: "GOS exception raised".
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Test the SOAP API for Inbound Delivery - Create (B2B).
- Attempt to create inbound deliveries via the interface.
- Observe the error message "GOS exception raised" in the SOAP Error log app.
Cause
In the payload file, the Attachment field is not maintained properly.
Resolution
- Refer to the sample payload in Attachment | SAP Help Portal.
- Correct the Attachment fields in the payload file.
See Also
Keywords
gos exception, soap api, inbound delivery, sap s/4hana cloud, attachment field, error log, payload, interface configuration, b2b , KBA , LE-SHP-API-2CL , Interfaces for Delivery Documents (API) (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions