SAP Knowledge Base Article - Public

3618811 - GOS exception error while creating inbound delivery via SOAP API interface in SAP S/4HANA Cloud Public Edition

Symptom

  • Encountering an issue while testing the SOAP API (Inbound Delivery - Create (B2B)) for the creation of inbound deliveries via the interface.
  • Error message: "GOS exception raised".

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Test the SOAP API for Inbound Delivery - Create (B2B).
  2. Attempt to create inbound deliveries via the interface.
  3. Observe the error message "GOS exception raised" in the SOAP Error log app.

Cause

In the payload file, the Attachment field is not maintained properly.

Resolution

  1. Refer to the sample payload in Attachment | SAP Help Portal.
  2. Correct the Attachment fields in the payload file.

See Also

Attachment | SAP Help Portal 

Keywords

gos exception, soap api, inbound delivery, sap s/4hana cloud, attachment field, error log, payload, interface configuration, b2b , KBA , LE-SHP-API-2CL , Interfaces for Delivery Documents (API) (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions