SAP Knowledge Base Article - Public

3618986 - Unable to import Talent Intelligence Hub attribute data through Integration Center

Symptom

You are unable to Upsert description data in the CSV file for the Talent Intelligence Hub attribute data, causing the import job to fail

Disclaimer: Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

  • SAP SuccessFactors HCM Suite
    • Integrations
      • Integration Center

Reproducing the Issue

  1. Attempt to import attribute data for Talent Intelligence Hub through Integration Center.
  2. Observe that the description data in the CSV file splits into different fields.
  3. Import job fails due to the splitting of description data.

Cause

The CSV import file contains additional commas and new line spaces or multiple spaces which impact the Integration Center job.

Resolution

To resolve the issue please update the source CSV file as mentioned below:

  1. Remove the additional commas from the description field in the CSV import file. Ensure that the description field does not contain any extra commas.
  2. Add double quotes ("...") at the start and end of the sentence, and a '\' character at the start of any special character.
    • Example:

      defaultLocale,externalId,name,description,type,status
      defaultLocale,externalId,name,description,type,status
      en_US,101-10599,Test Skill,"Lorem ipsum dolor sit amet\, consectetur\, adipiscing\, elit aenean vitae elementum massa.",SKILL,A

  3. Add a '\' character at the starting and end of the paragraph. This will make sure that the entire paragraph is updated in Description field
    • Example :

defaultLocale,externalId,name,description,type,status,id
en_GB,101_1058,Organisational change enablement,"\Facilitates cultural and behavioural change by enabling individuals and teams to embed new ways of working and adapt to changes.

Organisational change enablement is focused on the human and cultural aspects of change and supporting individuals and teams adapting to new work practices.
The key elements are: stakeholder engagement for commitment ongoing support for embedding changes and tailored communication addressing behavioural impacts and emotional readiness.
Activities may include but are not limited to:

facilitating engagement sessions with leaders and managers to secure commitment to change initiatives
defining communication strategies that address behavioural impacts and emotional readiness
supporting individuals and teams in adopting new ways of working providing resources for skill and behaviour development
addressing and resolving issues during the implementation of change initiatives to ensure minimal disruption
creating and managing networks of change agents to support and drive change
advising leaders on monitoring and supporting behavioural change and addressing challenges
establishing feedback processes to analyse the impact and effectiveness of change initiatives.\",SKILL,A,1228

List of special characters including but not not limited to the following:

  • !,@,#,$,%,&,*,(,),-,+,=,;,:,",',(comma), /,?,<,>,[,],{,},~,`
  • To make sure the import succeeds, include a leading '\'

See Also

Refer to: KB0023952 - Integration Center: Frequently Asked Questions

Keywords

CSV import, integration center, attribute data, description field, import job failure, inbound integration, additional commas, data splitting, attributeImport, LOD-SF-INT-INC-JOB , KBA , LOD-SF-INT-INC-JOB , Integration Center Job , LOD-SF-INT-INC , Integration Center , LOD-SF-INT-INC-FWK , Integration Center UI Framework , Problem

Product

SAP SuccessFactors HCM Core all versions ; SAP SuccessFactors HCM Suite all versions