Symptom
HCM Customers in Sovereign Cloud regions are unable to access the resume viewer when Latest Applicant Workbench and receive the following error
Online resume conversion failed.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Open Job Req
- Select Candidate application
- Select Resume
- Error: Online resume conversion failed.
- Similar error for cover letter as well
- All workflows involving Inline Resume Viewer will have the issue like Viewing Recruiting -> Candidate -> Search any candidates-> view resume, job Requisition -> Select multiple candidates-> Mass Print and Save
Cause
Sovereign cloud customers are on H2 2024 release
Resolution
The Resume Viewer is not available for Sovereign Cloud customers prior to the H1 2025 release. Until then, the only option was to download the resume file. Starting with the H1 2025 release, the Inline Resume Viewer is supported and enables file conversion for online viewing. To activate this feature, ensure the following setting is enabled in Provisioning:
Provisioning -> Company Setting -> Enable Inline Resume Viewer.
For H1 2025 release, this feature is controlled behind the feature toggle "RCM_CANDIDATE_DeprecateDocumentProcessingService_1730287290".
The toggle needs to be enabled in order to get this feature working.
Note: Users that don't have access to Provisioning will need to discuss with there implementation partner to enable the feature in Provisioning.
Keywords
Sovereign cloud, Resume Viewer , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Product Enhancement
SAP Knowledge Base Article - Public