SAP Knowledge Base Article - Public

3619482 - Document Blocks Field in Customer Account is Uneditable

Symptom

  • The Document Blocks Filed in Customer Account is Uneditable

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Account Management work center.
  2. Select the Accounts view.
  3. Open an account ABC (ABC represents the Customer Account Code).
  4. Navigate to the Sales Data tab.
  5. Observe that the Document Blocks field is uneditable.

Cause

The issue is caused by the 'READ ONLY' property being activated for the 'Document Blocks' fields in the key user settings.

Resolution

  1. Navigate to Key User Settings.
  2. Start Adaptation Mode.
  3. Click on the Documents Block input field.
  4. Right-click and select 'Set Read-Only'.
  5. Click 'Save' then click on 'Publish'.
  6. Stop the adaptation mode.
  7. The Document block will now be available to be edited.

See Also

Refer to : https://itsm.services.sap/kb_view.do?sysparm_article=KB0982547

Keywords

document blocks, uneditable, read-only, customer account, order block reason, Delivery block, Invoice block , KBA , SRD-CRM-ACC , Account Management , Problem

Product

SAP Business ByDesign all versions