SAP Knowledge Base Article - Public

3619687 - SAP Signavio Process Governance email task duplicate recipient prevention

Symptom

One user is added two times to an email task in SAP Signavio Process Governance, but is only getting email and is now missing the other email.

Environment

Approval Workflow for SAP Signavio.

Reproducing the Issue

  1. Configure a mail task within SAP Signavio Process Governance.
  2. Select both the Creator and Process Manager roles as recipients.
  3. Ensure the same user is assigned to both roles.
  4. Observe that only one email notification is received by the user.

Cause

The system recognizes duplicate email addresses within the email task and sends only one email to the user.

Resolution

If the email address is added twice into the email task (either directly or via participant roles), the system recognizes this and sends only one email to the user.

Keywords

sap process governance, email task, duplicate recipient, email notification, workflow, approval, email prevention, duplicate email, recipient roles, process manager, creator, sap workflow , KBA , BPI-SIG-CA-AWF , Approval Workflow for SAP Signavio , Problem

Product

SAP Signavio Process Governance all versions