Symptom
- After tranporting one permission group from source instance to target instance via CTC, some users were added in the group in target instance. However, those users were not existing in the same group in the source instance before transporting.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Login Source Instance and initiate a transportation of Permission Group via CTC.
- Login Target Instance and import the transportation.
- After the transportation completed, compare the users within the permission group between Source and Target Instances.
- It is verified that some extra users are appearing in the same group in Target instance.
Cause
The root cause is
- The Permission Group is using the filter of "User" by specifying the User ID.
- Some users in Source Instance, who were added in the permission group by User ID, were purged.
- However, the purge action will not erase the User Filter in Permission Group and the data will still remain in the database.
- Those purged user IDs could be verified by downloading the permission group using Download mode of CTC.
- When group was transported, the whole database table was copied and imported.
Resolution
Go to Manage Permission Group in Source Instance and Open the permission group filter page, you will see some blank columns in People Pool of User. Those blank records are the users who were already being purged.
Please delete the blank column and save the group filter.
After that, those purged users will not appear again after initiating a new transportation bundle.
Keywords
SAP SuccessFactors, Role-based permissions, Permission group, Configuration Transport Center, User permissions, data transfer, Manage permission group, Download mode, Filter table, Blank user, User purge , KBA , LOD-SF-PLT-CGC , Configuration Center , Problem