SAP Knowledge Base Article - Public

3620199 - Competency that is not mapped to the user's job appears in performance form section where only job specific competency should be present

Symptom

Performance template's competency section is configured with Job Specific competency option.

In the user's PM form additional competencies appear that are not connected to the user's role and not mapped to the position.

Environment

SAP SuccessFactors HCM Core 2505

Reproducing the Issue

  1. Open affected user's performance form.
  2. Observe the extra competency that is not related to the subject user's position in the competency section.

Cause

List of possible causes:

  1. If JDM to JPB migration was not complete it could cause such malfunction.
  2. If user's role was modified after the performance form was launched, the competencies that are related to the role won't appear on the form, as these kind of changes don't have an affect on live forms.

Resolution

Resolutions based on the above listed possible causes:

  1. Complete JDM to JPB migration.
  2. Launch new form for the affected user.

See Also

2228855 - JDM 2.0 Job Specific competencies not showing in PM form - SAP for Me

3344137 - Job Specific competencies from a specific competency category are not pulled to the performance form - Performance Management - SAP for Me

2086613 - Competencies Are Missing In a Performance Form - SAP for Me

Keywords

SuccessFactors, SF, performance form, PM, competency, section, job specific, additional, extra, plus, not mapped, not related, role, job profile, position, JDM, JPB, check tool, migration , KBA , LOD-SF-PM-FAM , Competencies Behaviors Families and Roles , LOD-SF-TIH-JPB , Job Profile Builder , Problem

Product

SAP SuccessFactors HCM Core 2505 ; SAP SuccessFactors Performance & Goals all versions