SAP Knowledge Base Article - Public

3620288 - Employee A has no access to section XYZ for employee B - SuccessFactors OData API

Symptom

You are trying to update some specific object for another employee using API, however it is failing with error below:

  • "Employee ABC(name of the employee performing the API call) has no access to section XYZ(name of the object) for employee 456(name of the employee to have the data udpated)."

Environment

SuccessFactors OData API Framework

Reproducing the Issue

  1. POST request to the obejct being updated
  2. Response Payload:

"error": {"code": "COE_GENERAL_FORBIDDEN", "message": {"lang": "en-US", "value": "Employee ABC has no access to section XYZ for employee 456."}}

Cause

The request failed due to no access. For global assignment, background elements are created and updated on the Home assignment. The User performing the API call does not have edit permission for home assignment on the target employee.

Resolution

Ensure that the user has permission to the Home Assignment.

In case you wish to understand why or how it works, refer to the following documents for further understanding:

See Also

0002477558 - How to work with SFOdata.Background_InsideWorkExperience entity - SuccessFactors OData API

https://help.sap.com/docs/successfactors-platform/managing-sap-successfactors-user-experience/enabling-person-based-custom-background-information?locale=en-US

https://help.sap.com/docs/successfactors-employee-central/implementing-and-managing-employment-lifecycle-from-hiring-to-termination/impact-of-multiple-employment-on-talent-profile-background-elements?locale=en-US

Keywords

error, access, section, employee, odata api, background elements, home assignment, permission, global assignment, update, api framework, successfactors , KBA , LOD-SF-INT-ODATA , OData API Framework , Problem

Product

SAP SuccessFactors HCM Suite all versions