Symptom
When opening the rules screen, for example Opportunity Rules, the rules are greyed out and not editable. Also the buttons as "swap", "upload", "Adapt" and etc are not clickable.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administrator > Sales and Campaign settings.
- Open Define Rules for Opportunity Parties.
- It is not possible to use any of the buttons or edit the rules.
Cause
If the Rules screen is not editable, is because another user have opened this same screen first. The user that opens it first will have the edit mode, while the next users won't have.
This is to avoid multiple users editing at the same time which could cause inconsistencies. The same behavior happens to other business object in the system.
Also, the message "Object locked by user" might appear in some cases.
Resolution
Ensure no other user has the same screen opened and the edit mode will be available.
Keywords
cannot edit, unable to edit, grayed out, click, clicking, unclickable, uneditable, read-only, read only, Sales Quotes, Sales Orders, Contracts, change, unchangeable, modify, modifiable, unmodifiable , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , LOD-LE-CQP , Customer Quote Processing , Problem