Symptom
Case creation is failing with error: "Please enter a party with role Contact of Account".
Even after adding a contact of the account, reprocessing the case creation fails.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to Settings.
- Go to Case creation monitor.
- Select the failed case .
- Select reprocess.
- The Case creation still fails even after the contact has been added to an Account.
Cause
This is expected behavior, as the contact was added after the email was received reprocessing the email will not work.
Resolution
A suggested workaround for creating cases from an unknown contact would be to create a default account and assign it to the email channel you are using for case creation. Then when a case is created from an unknown contact you can assign the correct account to the case and create a contact also.
Keywords
Please enter a party with role Contact of Account, case, account, contact , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem