SAP Knowledge Base Article - Public

3621256 - "Service is unavailable" error on idp-initiated login for SuccessFactors Mobile

Symptom

When using an idp-initiated login method for SuccessFactors on mobile, the following errors may occur.

  1. In case of a mobile app login attempt, the app will display the following error:
    "Service is unavailable, we apologize for the inconvenience. we are actively working to resolve the issue, please try again soon."
  2. When attempting a login in a mobile web browser, the company IDP will also display an error indicating a failed authentication attempt.
    NOTE: The specific error will depend on the company IDP used. For example Azure Active Directory will display an error code of AADST50020

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Mobile

Reproducing the Issue

  1. Open the SuccessFactors mobile app
  2. Select the "company name" method
  3. Search and select the company ID to login
  4. Error Received

Cause

Each record in the Mobile Activation Database can have one Company Name and one Login URL so SAP SuccessFactors on mobile only supports sp-initiated login, not idp-initiated login. 

Resolution

This is an expected behavior. Please ensure that user access the mobile app with sp-initaited login only.

See Also

  • KBA 2396645 - [SSO] SP Initiated Login
  • KBA 2577716 - How to add your company to the Successfactors App's authentication method? [SF MOB]

Keywords

service unavailable, login error, successfactors, mobile app, sso, azure, company name method, sp-initiated login, multi profile screen, authentication, AADST50020 , KBA , LOD-SF-PLT-MOB , Mobile Issues , LOD-SF-PLT-SEL , SSO Errors & Logs , Problem

Product

SAP SuccessFactors HCM Suite all versions