Symptom
Custom SAML mapping attribute changing from userID to emailID for 1 user in SAC
Environment
SAP ANALYTICS CLOUD 2025.8.6
Reproducing the Issue
- Login to SAC for user ID "xxxx"
- Navigate to Security > Users
- Notice the custom SAML column where the user ID is changed to email for this user only.
This happens each time the user "xxxx" logs in to SAC. For all other users the custom SAML mapping attribute is user ID.
Cause
User mapping is incorrect in custom IDP through which the SAML SSO is enabled in SAC.
Resolution
Reconstruct the SAML user mapping in the custom IDP for the particular user and then login to SAC.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
-
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Keywords
SAML, SSO, SAC, custom user mapping, custom IDP, custom SAML attribute, login, user, security , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem
Product
SAP Analytics Cloud 1.0
SAP Knowledge Base Article - Public