SAP Knowledge Base Article - Public

3621286 - Custom SAML mapping attribute changing from userID to emailID in SAP Analytics Cloud (SAC)

Symptom

Custom SAML mapping attribute changing from userID to emailID for 1 user in SAC

Environment

SAP ANALYTICS CLOUD 2025.8.6

Reproducing the Issue

  1. Login to SAC for user ID "xxxx" 
  2. Navigate to Security > Users
  3. Notice the custom SAML column where the user ID is changed to email for this user only.

This happens each time the user "xxxx" logs in to SAC. For all other users the custom SAML mapping attribute is user ID.

 

 

Cause

User mapping is incorrect in custom IDP through which the SAML SSO is enabled in SAC.

Resolution

Reconstruct the SAML user mapping in the custom IDP for the particular user and then login to SAC.

See Also

Keywords

SAML, SSO, SAC, custom user mapping, custom IDP, custom SAML attribute, login, user, security , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0