SAP Knowledge Base Article - Public

3621476 - Error message: supplier blocked in the Manage Purchase Order app

Symptom

While creating a purchase order in the 'Manage Purchase Order' app, the following error message is encountered: "Supplier xxxxx blocked". 

(where xxxxx represents the supplier number)

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to the app 'Manage Purchase Order'.
  2. Enter relevant details : Purchasing Group / Purchasing Org.
  3. Create a Purchase Order.
  4. The following error message is encountered 'Supplier xxxxx blocked'. 

Cause

The error occurs because a Purchasing Block is set for the specified supplier in the supplier master data. This block prevents the creation of purchase orders for that supplier.

Resolution

To resolve the issue, check and update the Purchasing Block settings for the affected supplier:

  1. Go to the Maintain Business partner app.
  2. Select the relevant Business Partner (supplier).
  3. Change Display in BP role as Supplier.
  4. Navigate to the Supplier:Status.
  5. Remove or update the Purchasing Block setting.
  6. Save the changes

Note: This block is applied at the level of a specific purchasing organization. When the Purchasing Block is set, the Business Partner is restricted from procurement activities only within the purchasing organization where the block is set. Other purchasing organizations within the company can still conduct procurement transactions with the same BP if they do not have this block in place. This block provides more granular control, allowing a BP to be active in some purchasing organizations but restricted in others solution.

Keywords

supplier blocked, purchase order app, purchasing block, maintain business partner, SAP S/4HANA Cloud Public Edition, vendor payments, procurement activities, purchasing organization , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , MM-FIO-PUR-PO , Fiori UI for Purchase Orders , Problem

Product

SAP S/4HANA Cloud Public Edition all versions