Symptom
- When searching for a Business Partner using the German alphabet "ß" in the First Name or Last Name fields in the Manage Business Partner app, no results are returned.
However, searching using the Business Partner number correctly retrieves the BP data. - In the Manage Business Partner master data app, entering "ß" in Last Name or First Name fields auto-converts to "ss", resulting in no matching Business Partner found.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to the 'Manage Business partner master data' app.
- Search for the Name (Example: Friß) in the Field 'Last name' or 'First name'.
- While searching 'ß' is changing to 'ss' and no business partner found.
Cause
This is standard system behavior when using the German characters in the First Name or Last Name search fields.
Resolution
As a workaround, use the Search field in the Manage Business Partner Master Data app or the Maintain Business Partner app.
- Go to 'Maintain Business partner' app.
- Change Find by to name.
- Search with the name (Example: Friß).
- The business partner details are found.
See Also
Keywords
search, german alphabet, ß, manage business partner, last name, first name, business partner number, sap s/4hana cloud public edition, workaround, maintain business master data app , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem
Product
SAP S/4HANA Cloud Public Edition all versions