SAP Knowledge Base Article - Public

3622174 - My Cases Query in Self Service Work List Displaying All Cases

Symptom

You notice that the My Cases query, in the Self Service work list, displays all cases rather than only the cases assigned to your name.

Environment

SAP Service Cloud Version 2.

Reproducing the Issue

  1. Logon to the SAP Service Cloud Version 2.
  2. Navigate to Self Service work list.
  3. Change the query to My Cases.
  4. See it displays all cases rather than only the cases assigned to the logged in agent.

Cause

The cases displayed in the Self Service work list are dependent on the access that the logged in agent has to the Case service, so if the business role of the agent does not have any restriction under the case service, all cases would be seen.

Resolution

it would be required to maintain a restriction for the case service for the agent business role, such as Myself, so that the agent only sees the cases they have reported.

Keywords

My Cases, Cases, Query, Restrict, Restriction, Business Role, Role, Role Restriction, Case Service, Myself, All Cases, V2, Version 2, SAP Service Cloud Version 2, Self, Service, Self Service, , KBA , CEC-CRM-SELF , ESM support for Self-Service module , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions