Symptom
There is a visit on C4C which was created using the Server Side add-on for a recurring meeting, after you change the date or time of the recurring meeting, the object is deleted on C4C.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Open the Outlook.
2. Search for visit "ABC" on Calendar.
3. Open it and change the visit time from "10pm" to "8:30pm".
4. Open the SSI add-on.
5. Send Update.
6. Force synch.
7. Go back to Visit's OWL screen.
8. Refresh.
9. The "ABC" visit object is missing on the tenant.
Cause
The issue occurs because modifying the recurrence results in all existing occurrences being deleted and replaced with new ones.
As a result, when these old occurrences are deleted during synchronization to C4C, any associated notes and details are also removed.
Resolution
This is a known Outlook limitation.
As a workaround, it is recommended to avoid changes to the recurrence pattern whenever possible.
Keywords
C4C; Outlook; Visit; Deleted; Delete; Appointment; Recurring; Modified; Changed , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To