SAP Knowledge Base Article - Public

3622435 - Error message raised by rule when editing or cancelling absence request when comment field is null

Symptom

  • Take rule has been configured to raise an error message if the comments field has not been filled.
  • If conditions of rule are If Employee Time.Comment is equal to Null.
  • Rule is raising an error message when cancelling an absence that already has a comment entered. 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central - Time Off



Reproducing the Issue

  1. Go to Time Off.
  2. Edit an existing absence where the comments field is already filled.
  3. Attempt to cancel or edit the absence.
  4. Save the changes.
  5. An error message is displayed by the rule, prompting to fill the comments field. 

Cause

The comment field of the existing employee time is being interpreted as null during cancellation, even if a comment already exists.

Resolution

  1. The current rule configuration doesn't work for all cases, e.g. edit. 
  2. Add another if condition in the rule - Edited Employee Time.Comment is equal to Null

Note: The processing action part is optional if required for all actions. 

See Also

2793169 - Business Rules Scenario Validations for Time Off

Keywords

absence request, cancel error, mandatory comments field, sap successfactors, employee central, time type, rule configuration, error message, null value, take rule , KBA , LOD-SF-EC-TIM-ABS , Absence error's - Calculations, Deductions, TT&ET , Problem

Product

SAP SuccessFactors Employee Central all versions