Symptom
- Inconsistent search results are observed when using the "Delete Form" functionality—specifically between the "Employee Document Folder" search and "Advanced Search".
- For example, searching for a user may return fewer forms under Employee Document Folder compared to Advanced Search or vice versa.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Performance Management
Reproducing the Issue
- Go to the "Delete Form" tool.
- Search for a specific user under the "Employee Document Folder" tab.
- Note the number of forms returned (e.g., 3 forms).
- Repeat the same search using the "Advanced Search" tab.
- Note that additional forms may appear (e.g., 4 forms).
Cause
The variation in results is due to design differences between the two search methods.
Resolution
This is the expected system behavior. The variation in results is due to design differences between the two search methods.
Users should select the appropriate search method based on their business needs for form deletion:
- Employee Document Folder retrieves forms where the searched user is included in the route map (i.e., the user is assigned to at least one step in the workflow).You can search for the forms in a specific user's Inbox, En Route folder, or Completed folder.
- Advanced Search retrieves all forms launched to the user, regardless of their participation in the route map.
See Also
Keywords
delete form, inconsistent search results, employee document folder, advanced search, sap successfactors, performance & goals, form deletion, route map, workflow, search methods, system behavior , KBA , LOD-SF-PM-ADM , Admin Center, RBP, Permissions and Settings , Problem