SAP Knowledge Base Article - Public

3623119 - How to trigger customer email templates with custom email trigger to recipients from different legal entity or location

Symptom

Customer want to trigger customer email templates with custom email trigger to recipients from different legal entity or location.

However for some candidate the email is triggered but for some not.

Reproducing the Issue

  1. Create a rule as per guide and added some conditions based on job information
  2. Maintain trigger rule to the Process object
  3. Process onboarding to trigger the email

Cause

The rule (Rules for MDF based objects scenario) maintained to Process Object takes the execution date as the effective date to fetch job info.

So if the start date of job info is in future, null will be fetched.

If the start date is in past, correct value will be fetched.

Resolution

  1. Remove all job info related conditions from the rule (Rules for MDF based objects scenario) maintained to the Process Object and ensure it will execute a common Email rule. Make sure only task status and task data is included to conditions.
  2. Ensure all email templates for different entities share the same common Email rule.
  3. Add filter email rules to each email template based on job info to meet business requirements. Make sure NO task status and task data is included to conditions.

By this way, once the task status and task data meet the conditions in trigger rule maintained to Process object, the common Email Trigger will be executed.

All email templates sharing the common Email Trigger will execute their own filter email rule.

The filter email rules will fetch job info based on the start date.

Only one filter email rule is met, and only one email will be triggered.

Note 1: Please make sure the correct content builder is maintained to the custom email category. 

For example, if it is not related to document, please do not use Onboarding Document Process Task Content Builder, as it will cause issue. 

Note 2: You can troubleshoot by creating a rule trace with BPE service user as the login user. 

For the Service user, you can find it from Update Process Flows for Onboarding and Offboarding.

See Also

Creating a Business Rule for Filtering Email Templates

Creating a Business Rule to Trigger an Email Notification When the Personal Data Collection Step is Completed

2257064 - Employee Central - Business Rule Execution Log 

Keywords

onboarding, sap successfactors, notifications, company code, email triggers, job info, effective date, filter email rules, UDF, mail server, recipient, process object , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions