Symptom
Task is not visible for task substitutes for task type <Clarify Invoice Exception for Supplier Invoice>
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Application and User Management work center and navigate to Task Substitutions view.
- Maintain employee B as the task substitution for employee A in the system and activate it.
- Go to Supplier Invoicing work center.
- Open one supplier invoice with exceptions and click on Save and Forward for Clarification.
- In the new pop-up window, select employee A and click on Send.
- It is expected that there will be a task with type <Clarify Invoice Exception for Supplier Invoice> sent to the substitution employee B's inbox, however this is not happening.
Cause
There are Key Differences between task forward and substitution:
- Scope: Forwarding is task-specific, while substitution is for all tasks.
- Timing: Forwarding happens at the time of task assignment or during task processing, while substitution is for an entire period.
- Automation: Substitution is automated, while forwarding requires manual delegation.
In general, Forward task can't stimulate further substitutions automatically. It's an option for forwarding uncomplete task to the employee being substituted. That' s why the forwarded task <Clarify Invoice Exception Price Variance for Supplier Invoice> won't be shown in the substitutes' inbox.
Resolution
This is the current system design.
If you would like this function in future release, please suggest an enhancement of this functionality, kindly turn to our Forum for new requirement proposals:
https://influence.sap.com/sap/ino/#/campaign/886
Keywords
Task substitutes, Clarify Invoice Exception for Supplier Invoice, Inbox, Tasks, Supplier invoice , KBA , AP-SIP , Supplier Invoice Processing , Problem
SAP Knowledge Base Article - Public