Symptom
Replicated Products cannot be deleted from the Products OWL.
Environment
- SAP Sales Cloud Version 2
- SAP Sales Cloud Version 2 and SAP Service Cloud Version 2
Reproducing the Issue
- Open Products workcenter.
- Navigate to Product Group menu.
- Notice that delete button is gray for the replicated Products.
Cause
The products cannot be deleted via UI because they were replicated from external systems. This is the current and expected system behavior.
Resolution
As a potential workaround, user can try removing the external ID using the "External ID Mapping" app, which can be accessed through User Menu > Settings > Integration > External ID Mapping.
Within this app, please:
-
Use the "Mapping Of" field to select the relevant external ID type.
-
Search for the product by using either the "ID" or "External ID" field.
-
Once you locate the correct entry, you can remove the external ID by clearing the value in the "External ID" field.
After all external ID entries associated with the product have been cleared, you should then be able to delete the product via the UI.
Keywords
Product , UI , Delete , OWL , Replication , External ID , KBA , CEC-CRM-PRD , Product for SAP Sales/Service Cloud , Problem