SAP Knowledge Base Article - Public

3623412 - Non-manager user can't see Continuous Performance Management activity data in table report

Symptom

Non-manager users can't access the data that is shared with them through Continuous Performance Management × Continuous Performance Meetings cross-domain table report.

Environment

SAP SuccessFactors Continuous Performance Management

Reproducing the Issue

  1. Share a Continuous Performance Management × Continuous Performance Meetings cross-domain table report that has 'Team View' team reporting type with a non-manager user
  2. Proxy as the non-manager user
  3. Run the shared report
  4. See that there is no data that is available for the non-manager user

Cause

This is expected system behavior.

Resolution

CPM has limited functionality in terms of the data being extracted from it.

As only the 'Team View' option is available in People Scope for Continuous Performance Management table reports subdomain schema, once you share the table report to others, the domain will pull the information based on the 'Team View' of the user (recipient) and the 'Team View' of the user who shared the report.

With 'Team View' option, data is exclusively available only for the Managers (and not meant for the HR Roles).

2495690 - Other Filters and HR Reports Options Missing Under People Scope - CPM - SAP for Me

Keywords

SuccessFactors, SF, table report, ad hoc, non-manager, user, no data, empty, continuous performance management, CPM, continuous performance meeting, cross, domain, team view, people , KBA , LOD-SF-CPM-REP , Reporting & Analytics, Data Imports & Exports , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , How To

Product

SAP SuccessFactors HCM Core 2505 ; SAP SuccessFactors Performance & Goals all versions