SAP Knowledge Base Article - Public

3623420 - [Error Code: 3] The provided username is already in use. Choose a different user name for Rehire candidate - Onboarding

Symptom

  • After Rehire candidate was initiated from Recruiting, an error was seen in Business Process tile [Error Code: 3] The provided username is already in use. Choose a different user name. 
  • Candidate did not initiate on Onboarding Dashboard.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

Situation 1 – Rehire with new employment:

  1. Initiate a Rehire candidate from Recruiting
  2. Candidate did not reach to Onboarding Dashboard
  3. Upon checking to-do dropdown and Business Process tile, we can see candidate appears with error: [Error Code: 3] The provided username is already in use. Choose a different user name. 
  4. Copy the Process Trigger ID
  5. Go to Manage Data > Process Trigger > and paste the ID for the affected candidate
  6. A incomplete profile appears, few information is available, but Rehire on New Employment is already triggered.
  7. Now go to Data Inspector > Table_User_SysInfo > enter the user name being selected > note how there is already an entry for this user name, with valid field as 'f' (inactive employee).

Situation 2 – Rehire with old employment:

  1. Initiate Onboarding from RCM.
  2. During the “Onboarding Rehire Verification” step, the candidate was identified as a “Rehire with old employment”
  3. When the candidate entered the “Manage Pending Hires”, onboarding process was cancelled
  4. This candidate was reinitiated onboarding from RCM
  5. Data Validation error: [Error Code: 3]The User Name you provided is already in use. Please select another User Name.
  6. Now go to Data Inspector > Table_User_SysInfo > enter the user name being selected > note how there is already an entry for this user name, with valid field as 'f' (inactive employee).

Cause

  • Cause of situation 1: "When a candidate is onboarded as a rehire on new employment, a new username is generated. Issue is happening once Rehire is triggered as soon as it reaches onboarding side. System recognizes it as already in use as a previous employment exists for this candidate.
  • Cause of situation 2: The username currently used by the candidate is the same as the username on the employee profile already in the system from their previous position, causing a data conflict.

Resolution

Solution for situation 1 – Rehire with new employment:

Implementation guide which better explains how the system behaves for username and rehire on new employment: Overview of IDs and Changes During Rehire Process | SAP Help Portal

User Name (Post employment)

User Name 1

Example: UName 1

User Name 2

Example: UName 2

User Name 2

Example: UName 2

When a candidate is onboarded as a rehire on new employment, a new username is generated.

At this point, the system will not allow us to proceed using the same username again. What you can do as a workaround: change the Primary email in SuccessFactors Recruiting and then restart the task in BPE.

I'm providing you a KBA where you'll be able to proceed with the Primary Email change if needed for the affected candidates (we can run a script) 3423305 - Data Validation: "The User Name you provided is not valid. Please use the following character types: ['a' to 'z', 'A' to 'Z', '0' to '9', '-', '_', '.', '@']." - Onboarding - SAP for Me 

Solution for situation 2 – Rehire with old employment:

  1. Change the username on this candidate's old employee profile to another username, for example, change A@123.com to A1@123.com. 
  2. Find this error in the BPE error card and click the Restart button.

See Also

Keywords

username, already, use, rehire, [Error Code: 3] The provided username is already in use, Choose a different user name, issue, bpe, business, process, tile, candidate, missing, onboarding, obx, rehire with old employment, rehire with new employment , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem

Product

SAP SuccessFactors Onboarding all versions