SAP Knowledge Base Article - Public

3623602 - "Looks like something went wrong" error when clicking on the Profile Preview button from the Team View page

Symptom

When accessing the "Profile Preview" section from the ILX Team View, the page throws an error:

"Looks like something went wrong. Please try again, if the issue persists, contact your system administrator.
Error Code: NotFound"

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Log into HCM as a manager > Navigate to Learning >
  2. Make sure the New Learning Experience is enabled >
  3. Navigate to Team View >
  4. Select any user > Profile Preview > An error is displayed.

Cause

This error have two possible causes:

  1. Manager should have the User Search permission in BizX (General User Permission) and a target population that includes their subordinates, so that he can access his subordinates people profile.
  2. The subordinate Person GUID in BizX is different from their Learning Person GUID.

Resolution

Resolution 1: Verify manager permissions.

  1. Go to Admin Center > User Role Search >
  2. Locate and open the role assigned to the affected manager >
  3. Click Manage Permission Roles and find that role again >
  4. Under General User Permission, add the User Search permission >
  5. Have the manager log out and log back in >

After this, the "Profile Preview" button should work correctly, allowing the manager to view their employee’s information without any errors. If the steps above did not resolve the issue, please proceed to "Resolution 2".

Alternatively, an enhancement ticket has been created to hide the Profile Preview icon when a user does not have permission to see the tile in BizX. This is under review by Product Management and does not have a defined timeline to be enhanced. Please set this KBA as favorite in order to be notified on future updates to this document, as per 2171560.

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Resolution 2: Verify the user Person GUID.

  1. Log into HCM and search for "Data Inspector," then open the feature >
  2. Under Entity, select "Table_USER_ACCOUNT" >
  3. Click "Add Filter Criteria" >
  4. In the first filter box, select "Username" >
  5. In the second filter box, select "Equals" >
  6. Enter the subordinate BizX Username in the last filter box >
  7. Click "Show Data" and get the Person UUID from the results.

The Person UUID obtained from these steps is the BizX Person GUID. To ensure that the User BizX Person GUID matches the User Learning Person GUID, run the User Connector SF, following the instructions in Change History | SAP Help Portal.

Note: Regarding the usage of the connectors, it is recommended to engage the SAP team that delivers Professional Services or an SAP Certified Partner to review and perform adjustments in the connector configuration (as per KBA 2404463).

See Also

Keywords

error, team view, SAP SuccessFactors Learning, integrated learning experience, user search, permission, manager, subordinates, profile access, enhancement ticket, people, profile, ppx, button, not found, something, went, wrong, person GUID, person UUID, LRN-200126 , KBA , LOD-SF-LMS-ILX , Integrated Learning Experience , Problem

Product

SAP SuccessFactors Learning all versions

Attachments

JDU-Issue-TeamView-NewILX-Error Displays when People Profile Card Clicked-Same End User-SameSoft (1).png