Symptom
When accessing the "Profile Preview" section from the ILX Team View, the page throws an error:
"Looks like something went wrong. Please try again, if the issue persists, contact your system administrator.
Error Code: NotFound"
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Log into HCM as a manager > navigate to Learning >
- Make sure the New Learning Experience is enabled >
- Navigate to Team View >
- Click on any user > Profile Preview > An error is displayed >
- Notice the affected user also does not have User Search permission in BizX.
Cause
Manager should have User Search permissions (General User Permission) and a target population that includes their subordinates, so that he can access his subordinates' people profile.
Resolution
- Go to Admin Center → User Role Search >
- Locate and open the role assigned to the affected manager >
- Click Manage Permission Roles and find that role again >
- Under General User Permission, add the User Search permission >
- Have the manager log out and log back in >
After this, the "Profile Preview" button should work correctly, allowing the manager to view their employee’s information without any errors.
Keywords
sf, lms, error, team view, integrated, learning, experience, ilx, user search permission, workforcepersonprofile, 404 code, not found, subordinate profile, role-based permissions, admin center, user role search, INC10071195, people, profile, something, went, wrong , KBA , LOD-SF-LMS-ILX , Integrated Learning Experience , Problem
Product
Attachments
JDU-Issue-TeamView-NewILX-Error Displays when People Profile Card Clicked-Same End User-SameSoft (1).png |