SAP Knowledge Base Article - Public

3623765 - Unable to View All Records in the Background Portlet of Employee Profile UI

Symptom

When we choose the Table view for the background element by default, only the top 100 records, maximum, will be displayed in the block ordered by the fields.

Environment

  • SAP SuccessFactors HCM Suite
  • SAP SuccessFactors Employee Profile

Reproducing the Issue

  1. Navigate to any employee -> Background Element -> Ctrl+F - search for any specific dated records (which have past dated records more than 100) > No records are shown.
  2. Click on the pencil/edit icon of the Background Element portlet ->  Ctrl+F - search for the same dated records checked above, and the records are visible.

Cause

This is an expected behavior. 

Resolution

  1. As per the system design, when the table view is selected for the background portlet, the first 100 records are visible in the employee profile UI.
  2. In case you want to see all the records in the employee profile, then kindly opt for "List View" of the background elements in the background block of configure people profile.

See Also

Chapter - Configuring a Background Information Block in Legacy People Profile

2803767 - Maximum Length for Background Element Data Fields

3033746 - Is it possible to highlight fields from background elements?

Keywords

Background element, employee profile, block, permission, limit, 100, pencil/edit icon, records, default, date, Table view, List view, INC13293172 , KBA , LOD-SF-EP-BGD , Background Elements , LOD-SF-EP , People Profile , Known Error

Product

SAP SuccessFactors Employee Central 2505 ; SAP SuccessFactors HCM Suite 2505