Symptom
When a Learning user is using Chinese or Japanese locales, the sorting of the Category names under Browse by Category does not seem to follow any logical ordering.
Normally we sort them alphabetically for other locales (based on Category description value).
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Go to your Learning page utilizing e.g. English locale
- Select Browse by Categories
- See that the Category names are ordered alphabetically
- Switch your language in BIZX to e.g. Japanese, Traditional/Simplified Chinese
- Navigate back to Learning
- Select Browse by Categories
- Notice that the Category names are ordered randomly and there is no visible logic in the sorting
Cause
Japanese and Chinese characters are converted into Unicode values to determine the sorting
Resolution
According to a confirmation from Product Management, Category names in Chinese/Japanese locales are sorted based on the following:
- System is encoding the Chinese/Japanese characters first and taking the Unicode corresponding value of them
- Then the application is determining the order based on those Unicode values
As this is the only method in the current system design how the application could logically order them when it comes to these type of characters, the ordering method is hardcoded for it.
We understand if this might not be considered by some of our Customers a user friendly approach, therefore we encourage you to vote on the following Enhancement Request on our Influence portal:
Influence request 346473 - Allow Custom Sorting of Library Categories
Keywords
unicode, categories, category names, browse by category, chinese, japanese, simplified, traditional, characters, ordering, order, sorting, sort , KBA , LOD-SF-LMS-ILX , Integrated Learning Experience , How To