SAP Knowledge Base Article - Public

3623857 - EmployeeTime Upsert Error: System error. Please contact administrator

Symptom

An upsert is being performed on EmployeeTime entity and the following error is observed: "System error. Please contact administrator"

Environment

  • SAP SuccessFactors EmployeeCentral
  • OData API

Reproducing the Issue

  1. Upsert on ExternalTimeData
  2. Right after an upsert on EmployeeTime is performed
  3. Failure happens

Cause

The upsert of ExternalTimeData triggers the background process to import the data into the timesheets. This may take some time (minutes to hours), depends on the system load and the number of employees. If upsert of EmployeeTime is performed in parallel (right after), this error happens, as the calculcation caused by the upsert on ExternalTimeData has not been completed yet.

In other words: The processes in parallel are the import of external times that requires a recalculation follow-up due to Single Approval Records being modified during the import. The import of absences require also a follow-up recalculation due to changed absence data influencing timesheet data.

Resolution

1st Option
As the calculation triggered by the upsert on ExternalTimeData might take minutes or hours, the upsert for EmployeeTime shouldn't happen at the same time as from ExternalTimeData, instead if should be executed in a period where no External Times are getting processed. This is tough when using CI/CO or another live integration, but should be easily preventable if the attendance data is also updated in bulk via an integration.

2nd Option
Instead of triggering ExternalTimeData first (which would trigger the calculation), the upsert of EmployeeTime can be executed first.
However, in a business context, this approach may introduce complications, as outlined below. It is recommended that you consult your implementation partner to verify and address these considerations. The Employee Time entity enables the submission of Leave of Absence requests. In contrast, External Time Data encompasses Clock-in and Clock-out records. Although these entities are not directly interconnected, External Time Data may contribute additional days that could be requested as Leave of Absence. Consequently, if a leave request submitted via Employee Time relies on anticipated days from External Time Data that are not yet available, the request may be rejected due to insufficient available days. 

See Also

Keywords

system error, CPI processing, WFM time entries, EC-time, SAP SuccessFactors, Employee Time, External Time Data, Time Management Task, recalculation, parallel processes, optimistic locking exception, import, upload, delay, payload , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , LOD-SF-INT-ODATA , OData API Framework , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions