Symptom
When opening the SAP Sales and Service Cloud Core App using the Microsoft Teams, a Single Sign-On (SSO) error message appears.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Open the Microsoft Teams.
2. Go to applications.
3. Search for SAP Sales and Service Core app.
4. Open this and select General Channel, then click Go.
5. Add your user and password.
6. Select the object, then click Save.
7. Click on Start Section.
8. A pop-up screen appears with a Single Sign-On (SSO) error.
Cause
The issue is happening because the Single Sign-On (SSO) is activated on the system, but is not correctly configured.
Resolution
The Single Sign-On (SSO) configuration should be completed correctly and be working properly on browser, so the same behavior should happen on Microsoft Teams.
Also, in case you have the Single Sign-On (SSO) activated, but your users are using basic authentication, you can disable the Single Sign-On (SSO) under Common Tasks work center, so the basic authentication screen should appear to the users.
Keywords
Microsoft Teams; SSO; Single Sign-On; Error; Basic Authentication; Message , KBA , LOD-CRM-TMS , Microsoft Teams Collaboration Channel , How To