Symptom
- In SuccessFactors it shows secondemail@email.com active however in IAS it shows firstemail@email.com which is incorrect.
- SCIM API is returning firstemail@email.com which is not correct as this is business email.
- Rehire welcome email is sent to business email or incorrect email.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- A user with email id firstemail@email.com gets terminated in SuccessFactors and synced to IAS.
- This same user is rehired later with a new email id: secondemail@email.com.
- In SuccessFactors it shows secondemail@email.com active
- However in IAS it shows firstemail@email.com which is incorrect.
Cause
The issue is caused due to incorrect Primary Assignment during the IAS user creation. This results in the IAS syncing the incorrect email address.
Resolution
- Engineering are aware of this issue and working on permanent fix in OBX-39380
- If you cannot wait for permanent fix to be deployed please refer to workaround
- Workaround:
- In Provisioning schedule the HRIS Sync Job to run every 30 minutes.
- Please download the attached BPMN definition
- Edit in notepad ++
- You will need to modify the service user
- You will need to adjust the delay
- What the goal of this custom BPMN is to delay the syncing of the user until the HRIS Sync job has been completed to sync the correct email
- Once updated we need to deploy the updated BPMN to the system
- Open Admin center
- Search BPE: Deploy Process Definitions.
- Select Choose File and Deploy (no need to fill the text fields).
See Also
Keywords
IPS, IAS, rehire scenario, SCIM API, email mismatch, HRIS Sync, BPMN definition, onboarding, user termination, user rehire, primary assignment, incorrect email, OBX-39380, INC13401212, welcome email, wrong email, old email , KBA , LOD-SF-OBX-IAS , IAS User Authentication , LOD-SF-OBX-RCF , Rehire Candidate Flow , Problem
Product
SAP SuccessFactors Onboarding all versions
Attachments
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SAP Knowledge Base Article - Public