Symptom
Standard fields "Marital Status" and "Date of Birth" are read-only despite not be set as read-only and have no binding or calculated field setting them to read-only in adaptation mode.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Customers Work Center.
- Go to individual customers view.
- Open an individual customer.
- Click on Edit Button.
- marital status and date of birth are grayed out and read-only.
Cause
The Individual Customers are Customer, that are also Service Agents. And for Service Agents, the Birth Date and the Marital Status is protected and the Birth Date Protected Indicator set to true. which means that this fields can’t be changed within the Individual Customers UI.
Resolution
Users should convert the Individual Customer via the “Create Service Agent from existing Business Partner” functionality in the Service Agents UI under Business Partner
- Go to Business partner work center.
- Go to Service Agents work center view.
- Click on New > Service Agent.
- Or Create Service Agent from existing Business Partner.
And if it's required ,please contact SAP Support to changed Birth Date Protected Indicator value to false in the Individual Customer in the backend.
Please note this change can currently only performed in the backend, and it is a very exceptional action.
Keywords
read-only fields, marital status, date of birth, standard fields, adaptation mode, backend binding, offline binding, individual customer, customer registration. , KBA , LOD-CRM-ACC-PRI , Private Account (Customers) , Problem