Symptom
Workflow is not triggered even the condition is met.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open a ticket and try to trigger the workflow rules.
- The action of the workflow is Escalate
- The condition is met and Escalation status should be changed from not escalated to escalated.
- But The workflow is not triggered.
Cause
In the tenant , there are two workflows are triggered in the same time, For example , if A field is updated from a to b when meet the condition in the first workflow ,and condition in the second workflow is the value changes from a to b for field A, then the second workflow will not be triggered . because all Fields Update and Action workflow rules are processed at the same time so this will not work this way.
Resolution
In order to make this scenario to work, you need to make the first workflow to 5 minutes after Changed On instead of on every save. This way, the first workflow will change field A from a to b after 5 minutes, and this will also trigger the second workflow rule.
Keywords
workflow, escalation level, field update, action, escalate, two workflows. , KBA , LOD-CRM-WKF , Workflow , Problem