SAP Knowledge Base Article - Public

3624192 - Main contact requirement when converting lead to opportunity for individual customers

Symptom

The main contact field is required when converting a lead to an opportunity for individual customers, even though individual customers do not have separate contacts.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales Work Center.
  2. Go to Leads Work Center View >> Open a lead.
  3. Click on Actions.
  4. Convert to Opportunity.
  5. Select an individual customer in Account field.
  6. The Contact field is still visible.

Cause

This is a current known system limitation.

Resolution

When converting a lead to an opportunity, the system does not automatically hide or make the Main Contact field optional based on the customer type. For individual customers, who don't have separate contacts, choosing a Main Contact doesn't make sense. Generally, contact field can be set as an optional. But since the field is required as mandatory, users have to select someone just to continue. After conversion, the contact field disappears, which is expected. We recommend simple customization to handle this automatically and make the process easier for users.

Keywords

main contact, lead conversion, individual customers, mandatory field, contact field, private customers, convert to opportunity. , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer core applications all versions