Symptom
During replication of a worker from External HR System to SAP S/4HANA Cloud Public Edition, following error is encountered: Business partner ID not found for workforce person XXXXXX with username CB&&&&&&&&.
Environment
SAP S/4HANA Cloud Public Edition
Cause
User ID that is used during worker replication already exists in S/4HANA System.
Resolution
To resolve this error, follow below steps:
- Open Maintain Business Users application and search for the corresponding worker of the CB User that is found in the error message.
- Follow this blog and documentation to schedule an ILM job to delete the data of the worker that was taken from step 1.
- Delete the corresponding CB user from Maintain Business Users application.
- Trigger the update/reprocess the failed message using the Message Monitoring Overview application.
Keywords
business partner id, workforce person, s/4hana cloud, replication issue, error message, profile creation, successfactors, ilm process, terminate work agreements, maintain business user, message monitoring, worker id, purged worker, S4_PC, S4_1C, CA-WFD-INT , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , Problem