SAP Knowledge Base Article - Public

3624347 - Unable To Create Email Channel

Symptom

User is unable to create new channel in system as the Create (+) button is not available in Channel Settings.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to Settings.
  2. Search for Emails.
  3. Navigate to Channels.
  4. Notice that there is no Create (+) button available to create new channel.

Cause

MTA Configuration was not saved or the configuration was saved with some inconsistency. Following error can be observed in Dev Tools (Ctrl + Shift + I) Network logs when Channels is loaded:

Request URL: https://<TENANT_URL>/sap/c4c/api/v1/email-mta-configuration-service/configuration
Request Method: GET
Status Code: 404 Not Found
Remote Address: 23.215.7.14:443
Referrer Policy: strict-origin-when-cross-origin
{
    "error": {
        "code": "emailMtaConfiguration.10001",
        "message": "Requested resource not found"
    }
}

Resolution

Performing a Save action in MTA Configuration as below will help resolve the issue :

  1. Go to Settings.
  2. Search for Emails.
  3. Navigate to MTA Configuration and click on Edit.
  4. Click on Save.
  5. Go to Channels and notice that the create (+) button is now available.

Keywords

Create, Channel, New, Emails, Configuration, 404 Not Found, MTA Configuration, Service, Channels , KBA , CEC-CRM-CHN , Channels for SAP Sales/Service Cloud , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0