Symptom
User is unable to create new channel in system as the Create (+) button is not available in Channel Settings.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to Settings.
- Search for Emails.
- Navigate to Channels.
- Notice that there is no Create (+) button available to create new channel.
Cause
MTA Configuration was not saved or the configuration was saved with some inconsistency. Following error can be observed in Dev Tools (Ctrl + Shift + I) Network logs when Channels is loaded:
"error": {
"code": "emailMtaConfiguration.10001",
"message": "Requested resource not found"
}
}
Resolution
Performing a Save action in MTA Configuration as below will help resolve the issue :
- Go to Settings.
- Search for Emails.
- Navigate to MTA Configuration and click on Edit.
- Click on Save.
- Go to Channels and notice that the create (+) button is now available.
Keywords
Create, Channel, New, Emails, Configuration, 404 Not Found, MTA Configuration, Service, Channels , KBA , CEC-CRM-CHN , Channels for SAP Sales/Service Cloud , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public