SAP Knowledge Base Article - Public

3624695 - Process Intelligence ServiceNow Table shows no Columns - Unable to obtain the schema for table: <table_name>

Symptom

ServiceNow Connection shows Valid and tables are available for selection in a Source Data instance, however, no columns appear for selection only a blank list.

If an attempt is made to preview the table or extract rows, an error similar to 

Unable to obtain the schema for table: <table_name>

Unable to preview columns - error Invalid columns in the preview request

Cause

The user account may not have the required authorization to access table schemas.

Resolution

To test, enter the following URL (replacing the appropriate instance and table names in the placeholders) in a web browser and use the credentials of the User used in the Process Intelligence ServiceNow connection when prompted.

https://{servicenow_instance}.service-now.com/{table_name}.do?SCHEMA

If the schema is not returned, ensure that the account used is provided with the required permissions in ServiceNow.

Keywords

ServiceNow, Schema, Table, soe, connection, SAP, Signavio, process, Intelligence , KBA , BPI-SIG-PI-DM , Data model / ETL for SAP Signavio Process Intelligence , How To

Product

SAP Signavio Process Intelligence all versions