Symptom
When attempting to duplicate a task in SAP Cloud for Customer (C4C), the following error message appears: "Please enter a reference document ID. | Save failed"
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to the Activity work center.
- Go to Task work center view.
- Open an existing Task XYZ (where XYZ represents the Task ID)
- Click on Actions > Duplicate Task.
- The error message is displayed: "Please enter a reference document ID".
Cause
The original task references a campaign whose status is set to "Canceled."
Duplicating a task with such a reference causes the system to prompt for a valid reference document ID.
Resolution
To successfully duplicate the task, follow one of the below options:
-
Use a similar task that does not reference a canceled campaign.
-
Alternatively, remove the campaign reference from the original task and then attempt duplication again.
Keywords
Error, duplicating task, save failed, reference document id, campaign, cancelled, activity, task , KBA , LOD-CRM-ACT , Activities , Problem
SAP Knowledge Base Article - Public