SAP Knowledge Base Article - Public

3624923 - Form routing error due to purged user in Route Map - Performance Management

Symptom

  • Performance form stuck in a step with a purged user.
  • Error message when moving the form forward: "route form failed: can't retrieve routeMapBean, company schema: xxxxx_STOCKPMxxxxx., folderMapId: -1".
  • Error message when moving the form a step back: "Couldn't find Owner for document xxxx; skipped".
  • Issue persists even after deleting and restoring the form.

Environment

  • SAP SuccessFactors Performance Management
  • SAP SuccessFactors 360 Reviews

Reproducing the Issue

  1. You have a Performance Management Form in a Route Step with a Purged User.
  2. Attempt to move a performance form forward in the route map.
  3. Observe the error message: "route form failed: can't retrieve routeMapBean, company schema: xxxxx_STOCKPMxxxxx., folderMapId: -1".
  4. Attempt to move the performance form a step back in the route map.
  5. Observe the error message: "Couldn't find Owner for document 3620; skipped".
  6. Delete and restore the performance form.
  7. Attempt to move the restored form forward or backward in the route map and observe the same errors.

Cause

The issue is caused by the performance form being stuck in a step with a purged user. The system is unable to find the purged user within the route map, causing the form to be in limbo.

Resolution

  1. Create a new performance form with the new manager or subject.
  2. Ensure the new form does not reference the purged user in any step of the route map.

There is no other workaround for this issue, unfortunately.

Keywords

performance form, purged user, route map, error message, sap successfactors, performance & goals, form stuck, route form failed, couldn't find owner, new form, manager, subject, Couldn't find Owner for document, skipped , KBA , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , Problem

Product

SAP SuccessFactors Performance & Goals 2505