SAP Knowledge Base Article - Public

3625210 - Users Unable to View Manually Sent Emails in Correspondence Portlet within New Applicant Workbench - Recruiting Management

Symptom

Users added to a job requisition are unable to view emails sent to candidates manually by other users in the Correspondence portlet within the application in the New Applicant Workbench.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Navigate to the Job Requisition.
  2. Ensure you are using the New Workbench to view the application.
  3. Go to the Activity tab and locate the email correspondence.
  4. Attempt to view emails sent manually by other users.
  5. Observe that the emails are not visible, while system-generated emails are accessible.

Cause

Engineering confirmed there was an unnecessary validation where the messages were shown only if the user logged in was the correspondence sender. As a result, the messages were not showing for other operators.

Resolution

The fix is scheduled for deployment in the 2H 2025 release. For more detailed information regarding release dates, please consult the SAP SuccessFactors Product Release & Road Map Information.

The fix ensures that messages sent via the 'Contact Candidate' option are visible to other operators, fulfilling the minimum requirement.

Note: As for messages sent via the Message Center, those message threads will remain restricted and accessible only to the correspondence owner.

Keywords

Correspondence, Portlet, New Applicant Workbench, Email Visibility, System-Generated Emails, Manual Emails, UXR, RCM-153075 , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions