Symptom
- Unable to re-initiate onboarding for a purged onboardee.
- The application page shows the message: "This applicant is already hired. User ID: xxx" even though the User ID has been purged.
Environment
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors Onboarding
- SAP SuccessFactors HCM Suite
Reproducing the Issue
- Purge the user account for the onboardee.
- In Recruiting, change the candidate's status back to Hirable.
- Try to re-initiate onboarding.
- Notice that the Initiate Onboarding / Reinitiate Onboarding option is greyed out.
- The application page shows the message: "This applicant is already hired. User ID: xxx".
Cause
The user account of the inactive onboardee hasn't been permanently purged.
Resolution
Permanently purge the inactive onboardee user. Use 'Data Inspector' to verify if the data was successfully purged.
For detailed instructions, refer to the KBA 3052056 - How to delete or permanent purge an inactive onboardee user - Onboarding:
- How to permanently Purge Inactive Onboarding users from the system:
- How to confirm if the data was purged successfully?
If after permanently purging the user, the status in Recruiting remains unchanged, consider rehiring the inactive user from EC. For more information, please refer to KBA 2079985 - How to Rehire an Inactive Employee - Employee Central.
See Also
KBA 3052056 - How to delete or permanent purge an inactive onboardee user - Onboarding
KBA 2079985 - How to Rehire an Inactive Employee - Employee Central
Keywords
RCM, ONB, Candidate, Reinitiate, Onboarding, Purge, Inactive, onboardee, Rehire, Employee , KBA , LOD-SF-RCM-ONB , Onboarding integration , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-RCM-APP , Applicants and Job Applications , Problem