Symptom
500 internal server error occurs when attempting to batch upsert job application records.
- Error writing the data:
{"requestUri":"/odata/v2/upsert","statusCode":500,"statusText":"","headers":[],"body":"{\n\"error\" : {\n\"code\" : \"ServerErrorException\", \"message\" : {\n\"lang\" : \"en-US\", \"value\" : \"Cannot invoke \\\"java.util.Map.size()\\\" because \\\"<parameter1>\\\" is null\"\n}\n}\n}"} - Cannot invoke "com.successfactors.rcmapplication.bean.JobApplication.getCustomizedStatusId()" because "oldJobApp" is null
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Try to batch upsert job application records using API.
- The error is received.
Cause
The batch upsert call contained duplicate Application IDs.
(For SAP Support: see internal memo for further details)
Resolution
To resolve this error, ensure that each upsert call includes only unique application IDs.
Keywords
RCM, API, CPI, Integration, Error, 500, internal server error, ServerErrorException, parameter1, java.util.Map.size, Job Application, update, upsert, BatchApply, getCustomizedStatusId, oldJobApp, null , KBA , LOD-SF-RCM-API , Webservices & APIs , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-RCM-APP , Applicants and Job Applications , Problem