SAP Knowledge Base Article - Public

3625429 - Migration of Leads Tool does not Import Records Successfully

Symptom

A file to be imported via the Migration of Leads tool contains multiple contacts for the same account. The migration tool processes the files successfully, but no records are imported and no errors are displayed.

Environment

Business ByDesign

Reproducing the Issue

  1. Navigate to the Business Configuration work center.
  2. Select the view overview.
  3. Search and find the activity: Migration of leads.
  4. Select "Migrate leads using the migration tool."
  5. Whilst maintaining the XML file, include multiple leads and Contacts for the same account.
  6. Execute the migration step-by-step.

The file processes successfully, but no records are imported, and no errors are displayed.

Cause

This is the system behavior.

In its existing framework, the lead migration tool does not support adding multiple contact details directly to leads during the migration process.

Leads will only successfully created only when the contact specified in the upload file is already assigned as the account's main contact in the master data, or alternatively when the contact details in the uploaded file are omitted.

Resolution

If the contact to be maintained in the new lead differs from the main contact, the following can be used as a workaround:

  1. Execute the migration tool without providing any contact details in the migration file.
  2. Once the lead is created, manually update the contact details in the user interface (UI) if needed.

Or

  1. Alternatively, use the web service "MaintainLeadIn", which can be used to create leads with contact details which differ from the main contact. See the help documentation: MaintainLeadIn Web Service Documentation.

Keywords

lead, leads, migration, error, migration tool, contact details, missing, import, marketing, work center, web service, MaintainLeadIn , KBA , SRD-CRM-MKT , Marketing , Problem

Product

SAP Business ByDesign all versions