SAP Knowledge Base Article - Public

3625681 - Admin cannot continue past identity information in Actions > New Hire Data - Onboarding

Symptom

  • When completing Actions > New Hire Data, the admin user cannot proceed past identity information.
  • Click continue and a Duplicate Check pops up, followed by the errors "The Person Id already exists. Please enter a new unique value" and "The User ID _____ already exists. Please enter a new unique value."

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Onboarding > select the affected onboardee > Action > New Hire Data
  2. See a hire template is in place
  3. Click continue, Duplicate Check pops up, it shows the employee which match the data is the exact same as the onboardees details.
  4. Click Ignore Matches.
  5. Error Message pops up - "The Person Id already exists. Please enter a new unique value" and "The User ID _____ already exists. Please enter a new unique value."

Cause

  • Identity Information section of the hire template should not contain any company specific attributes.
  • As a result, if the identity information portlet contains job information or compensation information, the duplicate check will appear.

Resolution

  1. Go to Manage Data > Hire template
  2. Select the template which is present in actions > new hire data for the affected onboardee
  3. Take Action > Make Correction 
  4. Move any company specific attributes from identity information to any other portlet
  5. Save

Keywords

Action, New Hire Data, Duplicate Check, Person ID, Hire Template, Identity Information , KBA , LOD-SF-OBX-NHR , Onboardee Data Review , Problem

Product

SAP SuccessFactors Onboarding