Symptom
Error "the email address is not unique" occurs when trying to edit an user.
Environment
- SAP Sales Cloud V2
- SAP Service Cloud V2
Reproducing the Issue
- Navigate to Settings > All settings.
- Access the "User" section.
- Search for the user desired.
- Attempt to change any data of the user.
- Observe the error message: "the email address is not unique."
Cause
The issue occurs because there are multiple employees in the system with the same email address, which violates the requirement for unique email addresses for each user.
Resolution
- Identify all employees in the system who share the same email address as the affected user.
- Update the email addresses of the duplicate employee records to ensure each email address is unique.
- Attempt to edit the user again.
- The error should not occur.
Keywords
Email, User, Employee, Unique, Edit, Error, IAM , KBA , CEC-CRM-IAM , Identity and Access Management for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions