Symptom
Data Impex tool shows an import task with more records than the file that was imported when using CSV file type.
Environment
- SAP Sales Cloud V2
- SAP Service Cloud V2
Reproducing the Issue
- Navigate to "Settings" > "All Settings".
- Access the "Data Import and Export" tool.
- Select "Create" and choose any entity.
- Upload a CSV file with e.g. 10 records.
- Click on the "Import Data" button.
- Observe that the system displays a total count of e.g. 20 records instead.
Cause
The issue occurs due to improper handling of CSV files where a single data entry is inadvertently split across multiple rows. This can happen if new line characters are introduced by the text editor used to create the CSV file.
Resolution
Ensure that the CSV file is created and formatted correctly:
- Avoid introducing new line characters within a single data entry.
- Identify the incorrect records by cross-referencing the imported data with the original file.
- Delete the incorrect records if necessary.
Keywords
CSV File, Import, Data Impex, Importing, Records , KBA , CEC-CRM-IMX , Data Import/Export for SAP Sales/Service Cloud , Problem
Product
SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public