Symptom
- Not all workflows created within a "Manage Workflows for..." app are transported to the target system during a software collection import.
- The workflows in question utilize teams created from the "Manage Team and Responsibilities" app.
- Transport logs show the following messages:
- Pre-Import of Team Mappings was not successful [scenario WSxxxxxxxx]
- Missing user(s) [scenario WSxxxxxxxx]
- No target team found for '<team ID>' [global ID <global team ID>, def <guid>, type Conditional Workflow]
Environment
S/4HANA Cloud Public Edition
Reproducing the Issue
- Create a workflow in a source system which utilizes a team in its configuration
- Create a software collection for the workflow scenario
- Import the software collection to a target system where the team used in #1 exists
- Observe that the workflow created in the source system was not transported to the target system
Cause
This behavior occurs because:
- the teams data are client dependent
AND - the software collection import process runs in client 000
Due to the above, the import process is unable to find and map the teams in question.
Resolution
Workflow developers are aware of the issue and are working towards a solution. There is currently no estimated delivery date.
The workaround is to reimport the transport via:
Manage Workflow Scenarios app -> open the workflow scenario in question -> click the "Re-import Transport" button.
This re-import activity takes place in the current client and so the team mapping error should not occur.
See Also
Keywords
re-import transport button, , KBA , BC-BMT-WFM , Business Workflow , Problem