SAP Knowledge Base Article - Public

3626171 - Supplier Invoice Status Update is sent twice from S/4Hana Cloud to Ariba Network

Symptom

When supplier invoice is received from Ariba Network and created in S/4Hana Public Cloud, there is an unnecessary second status update created for the supplier invoice.

Environment

SAP S/4Hana Cloud Public Edition

Reproducing the Issue

  1. Create Supplier Invoice in Ariba
  2. Supplier invoice is created in S/4Hana Public Cloud
  3. S/4Hana Public Cloud is sending the status update of the invoice twice

Cause

This is standard system behaviour.
The SOAP service incorporates a safety mechanism that may occasionally cause a status update to be transmitted twice. This infrequent behaviour is intentionally designed to mitigate the risk of losing a status update, which can occur if one of the participating systems experiences degraded performance. 

The logic behind this approach is that the potential impact of a lost status update outweighs the consequences of receiving a duplicate status update. 

Resolution

Standard system behaviour.

See Also

Supplier Invoice – Send Status Update Notifications (Outbound)

Keywords

Ariba Network, SOAP service, Supplier Invoice, Create Supplier Invoice, Status update, InvoiceStatusUpdateNotification_Out, API, MM-FIO_IV-2CL , KBA , MM-FIO-IV-2CL , Fiori UI for Invoice Verification (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions