Symptom
When importing multiple records with the same effective date, the business rule is not applied to the data in sequence number 2 and beyond.
Environment
SAP SuccessFactors Employee Central
- Employee Data Import
Reproducing the Issue
- Configure an onChange rule on Field A, setting Field B to be equal to Field A.
- Import two records for the same effective date, e.g., 5/22/2025, marning sequence 1&2.
- Observe that the rule is triggered successfully for sequence 1, but for sequence 2, the rule is triggered without applying changes to Field B, but reverting the value to the record which is before data import.
Cause
- The issue is identified as a product gap where the rule does not apply correctly to multiple records with the same effective date during import.
Resolution
As a workaround, import the records in separate import files to ensure the business rule is applied correctly.
See Also
Keywords
business rule issue, job information import, multiple records, same effective date, job classification, job level, job title, sequence number, sap successfactors, import workaround, product gap, rule not applied, onChange rule. , KBA , LOD-SF-EC-EDP-JOB , Job Information Imports , Product Enhancement
Product
SAP SuccessFactors Employee Central all versions