SAP Knowledge Base Article - Public

3626351 - SAP Cloud Integration is Unable to Process Initial Load Messages Of Registered Product Replication From SAP S4HANA To SAP Sales Cloud Version 2

Symptom

You have loaded all the registered products from S4HANA to Sales Cloud V2, but the messages are stuck in CPI with status Processing for longer intervals and will finally run into error

Environment

Integration for SAP Sales/Service Cloud v2 with SAP S4HANA

Reproducing the Issue

  1. Attempt to replicate approximately 200,000 registered product records from S4H to Sales Cloud V2 using CPI.
  2. Observe that the message processing gets stuck in CPI, and no requests are visible in Sales Cloud V2

Cause

CPI is unable to handle bulk message processing for large payloads due to system limitations.

Resolution

Consider using the standard iFlow for initial load, which processes messages through OData service instead of Event Mesh. Initial Load iflows are available for Functional Locations as well.

See Also

Refer to the following link for the standard iFlow:

https://api.sap.com/integrationflow/com.sap.s42cns.equipment.replication.initialload
https://api.sap.com/integrationflow/com.sap.s42cns.functionallocation.replication.initialload

Keywords

cpi, registered product, full load, sap service cloud version 2, message processing, enter customer error, bulk replication, s4h, sales cloud v2, odata service, integration, batch processing, custom iflow, tenant node restart , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Service Cloud Version 2 1.0