SAP Knowledge Base Article - Public

3626375 - You are already logged on to the SDK on system

Symptom

The below error message prevents the login to SAP Cloud Applications Studio:

  • You are already logged on the SDK on system XYZ. (XYZ refers to the system name)

Environment

  • SAP Business ByDesign
  • SAP Cloud for Customer
  • SAP Cloud Applications Studio

Cause

The issue occurs because a lock file is present in the computer, preventing a new login.

Resolution

Check for the presence of a lock file in the following paths:

  • For SDK Pilot: C:\users\<username>\documents\copernicusisolatedshell\Projects\<system>
  • For SDK Extension: C:\users\<username>\source\repos\<system>

If a lock is found, delete the lock file.

Alternatively, a lock can be found here: C:\Users\<username>\AppData\Local\SAP\SAPCloudApplicationsStudio\<system>\
You can then rename the system folder so the Studio will create a new one and the connection can go through.

Keywords

SDK, PDI, login, error, lock, You are already logged on to the SDK on system , KBA , AP-RC-BDS-SOL , ByDesign Studio Solution Explorer , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions